Back to overview
Some services are down
Feb 21 at 07:17pm CET
Affected services
Application
PVGIS
Resolved
Feb 21 at 07:17pm CET
PVGIS has solved itself. Back up and running.
Affected services
Application
PVGIS
Resolved
Feb 21 at 07:17pm CET
PVGIS has solved itself. Back up and running.
Affected services
Application
PVGIS