Back to overview
ESDEC Degraded. Multiple roofs not working.
Aug 09 at 03:52pm CEST
Affected services
Esdec
Resolved
Aug 09 at 03:52pm CEST
We are working with ESDEC to fix this issue ASAP.
Affected services
Esdec
Resolved
Aug 09 at 03:52pm CEST
We are working with ESDEC to fix this issue ASAP.
Affected services
Esdec